Troubleshooting
Problem
Note: Starting with IBM Spectrum Control 5.3.2, the HyperSwap volume status shown in Spectrum Control matches what is shown in the Storwize GUI. This rest of this technote applies only to earlier versions of Spectrum Control
The status for a Storwize vdisk might be reported differently at times such that the status in Spectrum Control and the Storwize GUI do not match. For example:
- Disconnected in Spectrum Control
- Offline in the Storwize CLI
- Online (green and healthy) in the Storwize GUI for the cluster
Cause
Spectrum Control collects and presents the status as reported by the Storwize CLI. The status in the Storwize GUI might not be caught up and in sync. With HyperSwap, a vdisk goes offline during periods of time while it syncs and then comes back online. The Storwize CLI and Spectrum Control GUI show this offline status, even if the Storwize GUI does not. Once the vdisk goes back online, the status in Spectrum Control is updated.
Diagnosing The Problem
Any offline vdisk is shown in Spectrum Control the same as it is reported by the Storwize CLI. Run one of the following Storwize CLI commands to compare the output to what Spectrum Control is showing.
lsvdisk
lsvdisk -filtervalue status=offline
Resolving The Problem
There is no problem to resolve here as the behavior is expected. However, the status of a volume can be acknowledged in Spectrum Control by right-clicking on the volume and selecting Acknowledge Status. Acknowledging affects the overall status of a device and is in effect until the volume status changes.
Note: Starting with IBM Spectrum Control 5.3.2, the HyperSwap volume status shown in Spectrum Control matches what is shown in the Storwize GUI.
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Document Information
Modified date:
22 February 2022
UID
ibm10718891