IBM Support

Step by Step Guide to linking IBM Rational Integration Tester to remote licenses on IBM Rational License Key Server on Windows

Question & Answer


Question

This is a step by step guide to linking IBM Rational Integration Tester (or IBM Installation Manager) to licenses on IBM Rational License Key Server on Windows.

Cause

Testers commonly use an IBM Rational License Key Server (RLKS) and need to connect to this from IBM Rational Integration Tester (RIT) in order to use the software. Administrators therefore need to know the steps to take in order to make this happen. (Note that this connection is tested from IBM Installation Manager (IM) rather then from IBM Rational Integration Tester.)

Answer

TCP Ports required

The license server itself is hosted by default on TCP port 27000. In order to enable the establishment of a remote connection it is necessary to run two other processes each with a TCP port, and these instructions will configure those ports to be 27001 and 27002.

To check that these ports are available on your license server before the license server is installed check that this command line instruction returns no output (or that any output specifies a port not to be used):




netstat -an -o|find ":2700"|find "LISTENING"

    Note: If the license server software is already installed the above test requires that the windows service "FLEXlm License Manager" is stopped.

    Alternatively use the PID number of the process hosting the port (shown in the final column on each line of the netstat output) and ensure the port belongs to the license software. (One way to do that on Windows 7 launch task manager and on the processes tab select "view", "add columns" to add the PID, remember to "show processes from all users" and then order by PID.) The license server processes are "lmgrd.exe", "rational.exe" and "ibmratl.exe".

    Also note: From IBM Rational License Key Server 8.1.1 onwards only one additional port is required. If you are following these instructions with RLKS 8.1.1 or above only ports 27000 and 27002 will be required.

Firewall rules to amend

Having established the three TCP ports to use (see above) ask the network services team to ensure that these TCP server ports can be reached on the given server from all clients on which IBM Rational Integration Tester is to be run. (There is often a lead time on changes to firewalls so it is best to do this now.)

Installing the license server software

Instructions on how to download and install the license server software are not included in this document. Such instructions can be found here:
http://www.ibm.com/support/docview.wss?uid=swg24032984
which links through to the Windows based installation instructions in the manual. It is also necessary to request license keys (if not already obtained) and import the license keys.

Configuring the license server software

The default installation of the license server does not permit any remote connection. To permit this we need to modify the one of the configuration files.

Firstly locate the installation of the license server (where lmgrd.exe is kept). Known locations include:
  • C:\Program Files\Rational\common
  • C:\Program Files\IBM\RationalSDLC\common
  • C:\Program Files\IBM\RationalRLKS\common
  • C:\Program Files (x86)\Rational\common
  • C:\Program Files (x86)\IBM\RationalSDLC\common
  • C:\Program Files (x86)\IBM\RationalRLKS\common
    Another way to locate this folder is to look at the properties of the "FLEXlm License Manager" service in control panel services, where it is given in the path to executable. (See restarting the license server below.)

This folder should contain the following files:
  • lmgrd.exe
  • ibmratl.exe
  • rational_server_perm.dat
And may contain these files:
  • rational.exe
  • lmgrd.log
    Note: rational.exe is not shipped with or required by RLKS 8.1.1 or above.
The file rational_server_perm.dat is a text file which contains configuration details for the license server. It will be necessary to edit this file in a text editor (such as notepad) which is capable of saving changes to the file. On some platforms it may be necessary to launch the text editor as administrator in order to save the changes. (To do this with notepad right click a short cut to notepad and select "run as administrator".) Where a line in "rational_server_perm.dat" ends with the \ character the line continues on the next line.

In the configuration file locate the line which defines the server and key. For example:

    SERVER GHLICSERVER DISK_SERIAL_NUM=1a1a4c8a 27000

After this line add an entry for "rational.exe" unless your installation does not include this binary (as with RLKS 8.1.1. or above). Ensure that the path to the file is correct for the system. For example:

    VENDOR rational \
    "C:\Program Files (x86)\IBM\RationalRLKS\common\rational.exe" \
    port=27001

After that line add an entry for "ibmratl.exe". Again, ensure that the path to the file is correct for the system. For example:

    VENDOR ibmratl \
    "C:\Program Files (x86)\IBM\RationalRLKS\common\ibmratl.exe" \
    port=27002

For the changes to rational_server_perm.dat to be applied the license server must be restarted.

Restart the license server

Launch control panel, administrative tools, services. and scroll down to the entry named "FLEXlm License Manager".

Right click this entry and select "start" or "restart" (only one of which should be available). It is sensible to check that the start up type has been set to Automatic.
    Note: To see the service's properties right client the entry and click properties. This can be useful in order to locate the file "lmgrd.exe", as the path to this file will be shown in the value "path to executable".

An alternate way to restart the service is to launch a command prompt as administrator and issue the relevant commands. To launch a command prompt as administrator right click a short cut to the command prompt and select "run as administrator". Here are the commands:

    C:\> net stop "FLEXlm License Manager"
    The FLEXlm License Manager service is stopping.
    The FLEXlm License Manager service was stopped successfully.

    C:\> net start "FLEXlm License Manager"
    The FLEXlm License Manager service is starting.
    The FLEXlm License Manager service was started successfully.

If the error "System error 5 has occurred. Access is denied." appears then it is likely that the command prompt was not started as an administrator.

Troubleshooting license server startup

If any errors occur during the start up of the "FLEXlm License Manager" service they should appear in the "lmgrd.log" (which will be in the same location as "lmgrd.exe"). This file is recreated each time the service is started. Sample output is shown below (with the initial block comment removed for brevity).

    12:58:55 (lmgrd) pid 26352
    12:58:55 (lmgrd) Done rereading
    12:58:55 (lmgrd) FLEXnet Licensing (v11.10.0.3 build 96515 i86_n3) started on GHLICSERVER (IBM PC) (2/5/2014)
    12:58:55 (lmgrd) Copyright (c) 1988-2011 Flexera Software, Inc. All Rights Reserved.
    12:58:55 (lmgrd) US Patents 5,390,297 and 5,671,412.
    12:58:55 (lmgrd) World Wide Web: http://www.flexerasoftware.com
    12:58:55 (lmgrd) License file(s): C:\Program Files (x86)\IBM\RationalRLKS\common\rational_server_perm.dat C:\Program Files (x86)\IBM\RationalRLKS\common\rational_server_temp.dat
    12:58:55 (lmgrd) lmgrd tcp-port 27000
    12:58:55 (lmgrd) Starting vendor daemons ...
    12:58:55 (lmgrd) Starting vendor daemon at port 27002
    12:58:55 (lmgrd) Using vendor daemon port 27002 specified in license file
    12:58:56 (lmgrd) Started ibmratl (pid 41788)
    12:58:56 (ibmratl) FLEXnet Licensing version v11.10.0.3 build 96515 i86_n3
    12:58:56 (ibmratl) Server started on GHLICSERVER for:
    12:58:56 (ibmratl) ibmrtw (consisting of: ibmrit
    12:58:56 (ibmratl) ibmrft ibmrpt ibmrpt_pvu
    12:58:56 (ibmratl) ibmrtw_ec)
    12:58:56 (ibmratl) EXTERNAL FILTERS are OFF
    12:58:56 (lmgrd) ibmratl using TCP-port 27002
    12:58:56 (ibmratl) Serving features for the following vendor names:
    ibmratl rational tlog_state telelogic tlog_rhaps

Checking the activity of the license server software

Before attempting to connect from the client it is a good idea to run the netstat and tasklist commands on the license key server to establish that the license software has opened services on the ports as expected. The last column of the netstat output is the PID, and this PID number is then re-used in the tasklist command.
    C:\> netstat -an -o|find ":2700"|find "LISTENING"
      TCP    0.0.0.0:27000          0.0.0.0:0              LISTENING       12632
      TCP    0.0.0.0:27002          0.0.0.0:0              LISTENING       14028
      TCP    [::]:27000             [::]:0                 LISTENING       12632
      TCP    [::]:27002             [::]:0                 LISTENING       14028

    C:\> tasklist /FI "PID eq 12632"

    Image Name                     PID Session Name        Session#    Mem Usage
    ========================= ======== ================ =========== ============
    lmgrd.exe                    12632 Services                   0      2,296 K

    C:\> tasklist /FI "PID eq 14028"

    Image Name                     PID Session Name        Session#    Mem Usage
    ========================= ======== ================ =========== ============
    ibmratl.exe                  14028 Services                   0      4,476 K

Checking the activity of the license server software remotely

The netstat command checks the ports are open on the server, when run from the server. The next step is to check that we can reach these ports from the client. On the client launch a command window and then use the telnet command to open a connection to the port, providing the server name.

The telnet command takes two parameters which are a host name and a port number. For example to determine that there is no TCP port numbered 27999 on host GHLICSERVER this command could be used.

    C:\> telnet GHLICSERVER 27999
    Connecting To localhost...Could not open connection to the host, on port 27999: Connect failed

When a telnet session can be established the command window will be cleared and the cursor will go to the top left. This shows that the port is active and contractible. To exit the telnet session press CTRL+C together.

This process should be repeated for each relevant port (typically 27000, 27001 and 27002). e.g.

    C:\> telnet GHLICSERVER 27000
    C:\> telnet GHLICSERVER 27001
    C:\> telnet GHLICSERVER 27002

Checking the connection from the client to the license server

Launch Installation Manager and select "Manage Licenses". Select "IBM Rational Integration Tester" and click radio button "Configure Floating license support" and then Next. Add (or modify) the license server definition to point to port 27000 on the server. From the License Server dialog click "Tests Connection" to ensure the connection can be established.



Click "OK" and "Finish". IBM Rational Integration Tester should now be able acquire licenses from the license server.

N.B. If you run this test connection from the server itself it will connect regardless of whether services "ibmratl.exe" or "rational.exe" are running. The test should therefore be done from a remote workstation.

Further reading

There is a more detailed technical document on the requirements of a remote connection to IBM Rational License Key Server here:
http://www.ibm.com/support/docview.wss?uid=swg21257370

[{"Product":{"code":"SSBLQQ","label":"IBM Rational Test Workbench"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Rational Integration Tester","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.0;8.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
11 July 2019

UID

swg21663805