IBM Support

Starting IBM Rational DOORS database server results in "Incompatible database format" error

Troubleshooting


Problem

Attempts to start the DOORS database result in the "Error failed to initialize database: Incompatible database format" error.

Symptom

When starting the IBM Rational DOORS database, you may see an error like:
-E- DOORS_DB_SERVER: Error failed to initialize database:
Incompatible database format

The database fails to start.

Cause

This error can be caused by insufficient permission or DOORS database corruption. For example:

  • If the server_settings.dtc file is missing or unreadable, it will cause this problem.

  • If you created a snapshot of the DOORS database while the database service was running, certain locked files may not be backed up. This database snapshot may thus be missing some important files.

Environment

This can happen on the DOORS database server machine on all supported platforms.

Diagnosing The Problem

There are a few areas to check in order to resolve this issue:

  • Verify that sufficient permissions are set for the database. The user that owns the DOORS application should have full access to the DOORS database. If the permissions are correct, you need to check for database corruption.

  • The simplest method to troubleshoot data corruption is to compare the problem database to a known good database, looking for file differences; for example, missing database configuration files. Both databases should be stopped when doing this comparison, to avoid getting sidetracked by differences in transient database files or lock files.

  • Another thing to check is the port number the problem DOORS service is using. Make sure that the database server port you intend to use is not being used by any other application. This type of error has been reported when the problem DOORS instance tries to use a port that is already in use by another DOORS database.

  • If you are having this problem while starting DOORS using a database snapshot, compare the size of the snapshot to the original database. The snapshot should be at least as big as the original. You should also ensure that the snapshot is not missing any key database files.

  • You can also enable DOORS debug server logging and examine the database logs. The logs will show that the client stops at a stage where the basic database files are loaded. Look for entries similar to:
    03/17/13 14:15:10 (PID 2420): Received packet: Packet connection id = 1363522500; packet seq/ack numbers = 5/5
    Class = File; Type = Exists;
    Arguments:
    String: /v6data/index.dtc
    Integer: 0

    This indicates the folder or file the DOORS client is looking for (in this case <DOORS data folder>\v6data\index.dtc). You will see an error when DOORS cannot find a file or folder it is expecting to exist.

Resolving The Problem

This problem is resolved by:

  • Correcting permission issues

  • Resolving an database corruption

  • Addressing any port conflicts

  • Stopping DOORS and recreating the database snapshot (if the problem is happening with a snapshot you created while DOORS was running)

If you need further assistance resolving this problem, please contact IBM Rational Technical Support.

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Document Information

Modified date:
01 May 2020

UID

swg21578485