Troubleshooting
Problem
User logs onto Citrix Storefront website. User clicks on the Controller icon, to try to launch Controller-on-Cloud. User receives an error.
Symptom
Citrix Receiver
Unable to connect to the server. Contact your system administrator with the following error:
SSL Error 4: The operation completed successfully.
Cause
Limitation of Controller-on-Cloud in some environments
Environment
Example:
In one real-life example, the client device (running Windows 10) had Citrix Receiver version 4.11 installed.
- However a different PC (also using Citrix Receiver version 4.11, but using Windows 7) worked OK.
Diagnosing The Problem
Inside your Windows control panel, look at your installed applications. Check the version of Citrix Receiver installed.
Example:
In one real-life example, the client device had this entry:
![](/support/pages/system/files/support/swg/cogtech.nsf/0/ac8387e3f7e0dfb385258297004ffba2/Diagnosis/0.284.gif)
Resolving The Problem
Downgrade client device to an older version of Citrix Receiver (Citrix client).
- In one real-life example, the solution was to downgrade to Citrix Receiver 4.6
- In a different real-life example, the solution was to downgrade to Citrix Receiver 4.9
Steps:
1. On the client device, open Control Panel
2. Uninstall the current version of Citrix Receiver:
3. Download an older version of Citrix Receiver
- In one real-life example, the solution was to downgrade to Citrix Receiver 4.6
- In a different real-life example, the solution was to downgrade to Citrix Receiver 4.9
Example: Downloading version 4.6.
At the time of writing this article, version 4.6 was available here: https://www.citrix.co.uk/downloads/citrix-receiver/legacy-receiver-for-windows/receiver-for-windows-46.html
![](/support/pages/system/files/support/swg/cogtech.nsf/0/ac8387e3f7e0dfb385258297004ffba2/Content/0.65C.gif)
4. Close all web browsers
5. Perform a default installation of Citrix Receiver (for example 4.6)
![](/support/pages/system/files/support/swg/cogtech.nsf/0/ac8387e3f7e0dfb385258297004ffba2/Content/1.1B72.gif)
6. Launch Citrix Storefront and test.
Was this topic helpful?
Document Information
Modified date:
12 October 2021
UID
swg22016667