IBM Support

SQL0624 Occurs During WebSphere Application Server Scheduler Resource Initialization

Troubleshooting


Problem

When starting an IBM WebSphere Application Server instance with a Scheduler resource configured, a SQL0624 - "Table XXX in YYY already has a primary key" message along with preceding CPD32B0 and CPF32B0 messages will be logged in the associated back-end QZDASOINIT/QZDASSINT or QSQSRVR database job log.  These messages occur because an ALTER TABLE SQL statement is executed by the Scheduler daemon to verify the primary key constraint exists on the Scheduler database tables.

Symptom

CPD32B0, CPF32B0, or SQL0624 messages are logged in the QZDASOINIT/QZDASSINIT or QSQSRVR job logs associated with the WAS Scheduler JDBC connections on the IBM i OS.

Message ID . . . . . . . . . :   CPD32B0                 
Message file . . . . . . . . :   QCPFMSG                 
  Library  . . . . . . . . . :     QSYS                  
Message text . . . . . . . . :   Constraint is not valid.
Severity . . . . . . . . :   20

Message ID . . . . . . . . . :   CPF32B0                               
Message file . . . . . . . . :   QCPFMSG                               
  Library  . . . . . . . . . :     QSYS                                
Message text . . . . . . . . :   Constraint cannot be added to file &1.
Severity . . . . . . . . :   40

Message ID . . . . . . . . . :   SQL0624                                  
Message file . . . . . . . . :   QSQLMSG                                  
  Library  . . . . . . . . . :     QSYS                                   
Message text . . . . . . . . :   Table &1 in &2 already has a primary key.
Severity . . . . . . . . :   30

Cause

This is working-as-designed.  The CPD32B0, CPF32B0, or SQL0624 messages are logged as a result of an ALTER TABLE SQL statement executed by the WAS Scheduler resource during initialization to verify the primary key constraint exists on the Scheduler database tables.  The WAS Scheduler resource is designed to properly handle the SQL0624 message returned and continue on with the initialization of the Scheduler resource.

Environment

IBM i OS; WebSphere Application Server

Diagnosing The Problem

Review the job logs for the QZDASOINIT/QZDASSINIT or QSQSRVR jobs associated with the WAS Scheduler JDBC connections on the IBM i OS.

QZDASOINIT/QZDASSINIT jobs
WRKACTJOB SBS(QUSRWRK) or WRKACTJOB SBS(QSERVER)

QSQSRVR jobs
WRKACTJOB SBS(QSYSWRK)

Resolving The Problem

IBM has investigated the CPD32B0, CPF32B0, and SQL0624 messages related to the WAS Scheduler service; and found this is working-as-designed.  In order to support multiple, heterogeneous database management systems and prevent additional WAS Scheduler functionality issues; IBM chose to use the ALTER TABLE SQL statement to verify the existence of the primary key constraint on the Scheduler database tables.  This will also allow the WAS Scheduler daemon to add the primary key constraint on a table if it is found missing.

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Component":"WebSphere Application Server","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}},{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
18 December 2019

UID

ibm10720099