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SQL Agent - Workspaces show no data; SQLSTATE: 08001, Native error: 6

Troubleshooting


Problem

Tivoli Enterprise Portal workspaces for ITCAM agent for Microsoft SQL Server agent show no data. Agent's collector log (*.out) has "SQLSTATE: 08001, Native error: 6" messages.

Symptom

Collector log (*.out) shows following errors:

FXR4024T (100412) (6096)Call Exit koqsql, Parms -logon itmmon -password ...== -rdbms SQLSRVR 3 master "select convert(char,len(@@version),2),'1'" .
MSU0500I (100429) (6096)SQLSTATE: 08001, Native error: 6, Message: [Microsoft][ODBC SQL Server Driver][DBNETLIB]Specified SQL server not found.
MSU0500I (100429) (6096)SQLSTATE: 01000, Native error: 11004, Message: [Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).
MSU0425E (100429) (6096)Database open failed. Server: SQLSRVR User:tivoli.
CGN1522S (100447) (6096)Restarting collector 08/26/13 10:04:47
GGN1505S (100447) (6096)Time = 2013/08/26 10:04:47, Collector ended

Cause

Agent is getting bad port for SQL connection.

Resolving The Problem

Set value of COLL_PORT = 0 in following registry path.
HKEY_LOCAL_MACHINE\SOFTWARE\Candle\KOQ\610\<Instance Name>\Environment

Restart the agent. Check Tivoli Enterprise Portal workspaces of SQL agent for monitoring data.

[{"Product":{"code":"SSDKXQ","label":"Tivoli Composite Application Manager for Microsoft Applications"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Microsoft SQL Server Agent - 5724B96MO","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3.0;6.3.1;6.3.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21654965