IBM Support

Sort by Count does not work in a Distributed Report

Troubleshooting


Problem

You are using a report with the built-in "Add Count" and "Sort by Count" checked.  The report runs as expected and sorts by the count when it is run against a single datasource.   However, when the report is used in a distributed report to run on a group of collectors, the "Sort by Count" isn't used.  The report runs on each collector and exports the results just as they are imported into the end result report.    You want all the results totaled and sorted in the final report. 

Cause

Distributed Reports (DREP) create their own entity including such fields as datasource and timezone. The count now uses the datamart extraction ID.  DREP are based on datamarts. 

Resolving The Problem

In the base query for the report, do not use the "Add Count" check box.  Instead, add the entity ID attribute into the field list with the "Count" field mode.  For example, if the main entity is "Sessions", use the Session ID.  If the main entity is "Exceptions", use the Exception ID. 

Create the distributed report in the Distributed Report Menu. 
In the Data Marts menu, the Domain Finder will show the distributed report with 'Distributed' appended (<report name>-Distributed).  Select the domain > search > select the query name. 
In the query builder, open the entity by clicking on the entity name in the left column.  Note the last field is the "Count of <entity ID>" from the original report.  This attribute in the query will have a "value" field mode that you can check  "order by".   The DREP should now show the results sorted by count. 

Document Location

Worldwide

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Document Information

Modified date:
20 May 2019

UID

ibm10885012