IBM Support

SOAR: All deployed applications stop functioning after renaming an Organization

Troubleshooting


Problem

Changing an Organization name causes all deployed applications to stop functioning.

Symptom

In the app.logs, after an Organization name is changed, receive error:
Exception: The user is not a member of the specified organization Soar43-1

Cause

When the organizational (ORG) name is changed, the apps settings need to be updated as well.
For example, when ORG name is changed from 'Soar43-1' to 'SOAR47':
resutil editorg -orgname "ExistingOrgName" -name "NewOrgName"
resutil editorg -orgname "Soar43-1" -name "SOAR47"

Environment

App Host

Resolving The Problem

  1. For applications deployed to the IBM Security QRadar SOAR App Host:
    1. Open the app.config in the SOAR UI by selecting Administrator Settings > Apps > {application} > Configuration tab.
    2. Locate the [resilient] section.
    3. Edit org = <old_org_name> to org = <new_org_name>.
      For example, this old ORG name:
      old org name
      Changes to:
      org name new
    4. Repeat steps for each application.
  2. For applications deployed to the IBM Security QRadar SOAR Integration Server:
    1. Open the app.config file.
      Note: The default location for the app.config file is:
      /home/integration/.resilient/app.config
    2. Edit the [resilient] section
    3. Changing org = <old_org_name> to org = <new_org_name>

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSA230","label":"IBM Security QRadar SOAR"},"ARM Category":[{"code":"a8m0z0000001jTpAAI","label":"Integrations-\u003EAppHost"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
06 February 2023

UID

ibm16857279