IBM Support

SNMP traps not being sent for IBM Control Center

Troubleshooting


Problem

IBM Control Center (ICC) is set to monitor for alerts on an IBM Sterling File Gateway (SFG) instance, and generate SNMP traps for them. Monitoring systems are not receiving the SNMP traps from ICC.

Cause

ICC is not receiving all the alerts from SFG in a timely fashion when SFG generates large amounts of alerts in rapid succession.

Diagnosing The Problem

Check the recordLimit and timeout values that are set in CCEngineService.xml

Resolving The Problem

1. Increase recordLimit in <install-dir>/conf/services/CCEngineService.xml, for example from <recordLimit>2500</recordLimit> to <recordLimit>4999</recordLimit>

2. Change the SFG server connection timeout values from for example 120 to 600

Please note that CCEngineService.xml updates require a engine recycle to take effect.

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.1;6.0;5.4.2.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg21991130