IBM Support

sls api-licensing pod fails to pull image after upgrading to MAS catalog

Troubleshooting


Problem

After you upgrade the IBM Maximo application suite (MAS) catalog for installing MAS 8.11, the api-licensing pod in the ibm-sls namespace fails to pull the new image.

Symptom

In the ibm-sls namespace, the api-licensing pod fails to pull the image with the error.
Error: Failed to pull image "cp.icr.io/cp/ibm-sls/api-licensing@sha256:382be651a9a56572a222677bbe7013952d4bcfa3d68926265fb0929f12845b01": rpc error: code = Unknown desc = reading manifest sha256:382be651a9a56572a222677bbe7013952d4bcfa3d68926265fb0929f12845b01 in cp.icr.io/cp/ibm-sls/api-licensing: denied: You are not authorized to access the specified resource. See https://cloud.ibm.com/docs/Registry?topic=Registry-troubleshoot-access-denied

Cause

When the catalog is updated, a new version of the SLS operator is installed, 3.8.0. This new version reconciles the "License Service" custom resource.
However, the existing custom resource of type "License Service" contains a reference to the image registry "cp.icr.io/cp", the new operator references an image, which is in "icr.io/cpopen".

Resolving The Problem

In the Red Hat OpenShift console, go to operators > installed operators.
Change the project to ibm-sls. 
Select the "IBM Suite License Service" operator.
Click "License Service".
Click the instance name, "sls".
Click YAML.
Edit the YAML to update the spec.settings.registry field to "icr.io/cpopen".
update license service

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m50000000CbD5AAK","label":"Upgrade"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.11.0;and future releases"}]

Document Information

Modified date:
16 October 2023

UID

ibm17052824