IBM Support

SIMPLimitExceededException occurred while sending messages to a queue

Troubleshooting


Problem

When using the WebSphere Application Server (WAS) Message Engine, at either the client or applicaiton side you see this exception: SIMPLimitExceededException and your application or client is unable to send the messages to the SIB desination and requests are failed. In the SystemOut.log, the following exception is thrown: javax.jms.JMSException: CWSIA0067E: An exception was received during the call to the method JmsMsgProducerImpl.sendMessage: com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIK0025E: The destination on messaging engine is not available because the high limit for the number of messages for this destination has already been reached..

Cause

This error implies that the queue point (or remote queue point) for which the application is producing has exceeded its high message threshold.

The error can occur for a topic as well.

Resolving The Problem

1) Check the current message depth of the queue point. If the message depth is at or above the high message threshold we expect this exception. Reasons this could happen are:


    a) No consumer is actively consuming the messages from this queue point. Ensure that each queue point has an active consumer.
    b) The active consumers cannot consume messages at a rate equal to the rate at which the producers are producing them. You can resolve this in one of two ways:
      i) Increase the speed of the consumer applications; for example, increase the number of threads used by an MDB, or connect consuming applications directly to this messaging engine.
      ii) Reduce the speed of the producing applications.

2) If the queue point has not reached the high message threshold, the failing producing application might be connected to a messaging engine that does not own the queue point for the destination. A remote queue point has been created by this messaging engine and the messages have been built up here:
    a) Identify which messaging engines the producing application was or is connected to.
    b) For this messaging engine, identify the remote queue points.
    c) Check the current outbound message value of the remote queue point. If this value is high or it has reached the high message threshold of the messaging engine then you see this exception, check the following areas:
      Determine if the outbound messages sent value is increasing over time. Refresh the panel after a few seconds to see if the number changes:

      i) If the outbound messages sent value is not increasing, make sure the remote messaging engine that owns the queue point is running. If not, start it. After the messaging engine is started, the outbound messages should drain from the remote queue point into the queue point. If the messages are not sent, examine the application server SystemOut.log files and search for occurrences of message CWSIT0029I. If you see this message, check the message body to see if the messaging engines match those hosting any queue points that interest you.
      For example: CWSIT0029I: The connection for messaging engine ME_1 in bus <Bus_Nam> to messaging engine <ME_2> stopped.
      This message generally implies a network connectivity problem. Resolving connectivity issues enables the messages to be delivered to the queue point.

      ii) If the outbound messages sent value is increasing, messages are successfully being transmitted to the corresponding queue point. The reason for the large number of outbound messages is that the rate of message production is faster than they can be transmitted. This situation might be due to a slow network connection between messaging engines or to other network traffic interfering with this connection’s performance. Improving the network connection should increase message throughput. If it does not, the message production rate must be reduced to prevent the backlog.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Service Integration Technology","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.0;8.5.5;8.0;7.0","Edition":"Base;Network Deployment","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSFKSJ","label":"WebSphere MQ"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Configuration","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSQH9M","label":"WebSphere Process Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSWLGF","label":"WebSphere Service Registry and Repository"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SS7NQD","label":"IBM Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SS7J6S","label":"WebSphere Enterprise Service Bus"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSDKKW","label":"WebSphere Partner Gateway Advanced Edition"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB02","label":"AI Applications"}},{"Product":{"code":"SSDKJ8","label":"WebSphere Partner Gateway Enterprise Edition"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":null,"Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Product Synonym

WebSphere Application Server WAS SIB SIBUS SI BUS

Document Information

Modified date:
15 June 2018

UID

swg21624736