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Setup Inbound email has problem with server certificate

Troubleshooting


Problem

After setup an email connection from "Administrator Settings > Organization > Email Connections > Inbound", run "Test Connection" receive error:
Connection to mailbox xxx failed. There was a problem with the server certificates. The server certificates must be working correctly to complete the connection.

Symptom

You can see the following error in the Inbox setup page:
error

Cause

This error indicates the Mail Server certificate is not accepted by the resilient server.  It needs to check the resilient-mail.log to find the root cause. The mail certificate needs to be trusted by Resilient Server.

Environment

Any version of IBM SOAR System.

Diagnosing The Problem

Check the resilient-mail.log, you see the following error:
for example
ERROR v=unknown  c.r.e.SelfSignedCertificateAwareTrustManager - Error checking mail server certificates:
java.security.cert.CertificateException: None of the TrustManagers trust this MAILSERVER certificate chain.
	at com.resilient.email.SelfSignedCertificateAwareTrustManager.checkServerTrusted(SelfSignedCertificateAwareTrustManager.java:85)
	at com.ibm.resilient.camelcomponentews.EmailHostnameVerifier.verify(EmailHostnameVerifier.java:83)

Resolving The Problem

Please follow the solution:
1. Obtain IMAP server's certificate:
echo | openssl s_client -connect <IMAP-server>:993 | sed -ne '/-BEGIN CERTIFICATE-/,/-END CERTIFICATE-/p' > mail_cert.pem
Or you are using exchange OutLook 365.  You can obtain it by
echo | openssl s_client -connect  outlook.office365.com:443  | sed -ne ‘/-BEGIN CERTIFICATE-/,/-END CERTIFICATE-/p’ > mail_cert.pem
 
2. Go to the email connection page, under the error drag the file "untrusted_cert.pem" to the area "Drag certificates here".
Drag and drop

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSIP9Q","label":"IBM Security SOAR"},"ARM Category":[{"code":"a8m0z000000cvv5AAA","label":"Email"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
27 July 2021

UID

ibm16476166