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"Service Control Manager 7011" message is logged when stopping the Server

Troubleshooting


Problem

When the Tivoli Storage Manager server is stopped using the Microsoft Windows Service panel, an error message can be logged in the Windows System Event Viewer system registry.

Symptom

The message is:

"Service Control Manager 7011 None A timeout (30000 milliseconds) was reached while waiting for a transaction response from the TSM Server1 service."

When stopping the Tivoli Storage Manager server with the "halt" command, no errors are reported.

Cause

Microsoft Windows has a hard coded time of 120 seconds for a service to stop.
With the Microsoft "Process Monitor" tool it is possible to verify that the timeout message is raised because of the "db2stop.exe" - which is part of the Tivoli Storage Manager Server stop process - is taking more time to complete.

Resolving The Problem

To avoid the "Service Control Manager 7011" message it is possible to increase the timeout via the Microsoft technote "Event ID 7011 — Basic Service Operations" (see link below).
Or the problem can be skipped by using the "halt" command on the Tivoli Storage Manager Server Administration command line.

[{"Product":{"code":"SSSQWC","label":"Tivoli Storage Manager Extended Edition"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.2;6.1;6.3;6.4","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21644210