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Service argument changes do not reflect until the restart of integration server.

Troubleshooting


Problem

Attempts to change service arguments of integration server does not reflect changes in IBM Sterling Order Management.

Symptom

While running a service, the requirement is to change the arguments on the fly. While the system allows it to be changed and even saved successfully, the changes made do not reflect until the server is restarted.

Steps to replicate:

  1. Create a service (say service1) which pushes messages to a messaging queue.

  2. Create another service (say service2) which consumes the messages placed in messaging queue by service1.

  3. Start the integration server associated with service2.

  4. Run/call service1 to push a message in the queue.

  5. Change one of the arguments/parameters associated with service2. (change the API name) and Save

As a result, the service2 still executes with old API name. The new API name is not considered.

Cause

This is working as designed.

Diagnosing The Problem

When first time any service is invoked all the components are initialized and cached under the JVM. So when this service is called again the configurations are fetched from cache. This is done to avoid re-initialization of service per call. Hence, the changes made before the start are stored in JVM cache and further changes will only be applicable once the JVM is restarted.

Resolving The Problem

Restart the JVM after making changes in the service argument.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21977085