IBM Support

'The secure connection failed...' error starting Rational DOORS 9.3 client

Troubleshooting


Problem

Attempts to start an IBM Rational DOORS 9.3 client to connect to a recently upgraded DOORS 9.x database results in the error "The secure connection failed.".

Symptom

After a working IBM Rational DOORS 9.x database is upgraded to DOORS 9.3, you cannot connect to the database with the DOORS 9.3 client, but you can still connect to it with an older DOORS 9.x client.

The IBM Rational DOORS 9.3 client fails to start with the following error:
The secure connection failed.
.The secure socket was forcibly closed.
DOORS will now exit.

Cause

One cause is that the IBM Rational DOORS database has Maximum client version set to a version older than 9.3.

Diagnosing The Problem

When you get this error, the first thing you need to do is verify that the IBM Rational DOORS 9.3 client can connect to other databases. If it can, you know it is a good installation.

Once the client installation has been validated, you need to verify that the database is still sound, which it should be -- the easiest way to do this is to connect to the database with an older DOORS client.

If the problem is with the database, connecting with an older client will display a different error, which will provide further insight into the cause of the problem. If you cannot connect with the older client, please contact Support and provide all errors.

If you can successfully connect with the older client, it will give you a chance to inspect the database for issues and to verify that the database is not configured to prevent the DOORS 9.3 client from connecting.

Resolving The Problem

While connected with the IBM Rational DOORS client, check your database's "Maximum client version" setting:

  1. If you did not log in as Administrator, please restart the DOORS client and log in as Administrator.

  2. With DOORS in Database View, right-click the DOORS database and choose Properties.

  3. In the Database Properties window, click the Login Policy tab.

  4. In the Client Versions section, ensure that "Maximum client version" is blank. NOTE: "Minimum client version" can remain set per your needs.

If "Maximum client version" had been set to a version older than 9.3, this would prevent the 9.3 client from connecting. Once that restriction is removed, you should be able to connect with the 9.3 client.

If you still cannot connect with the DOORS 9.3 client after clearing Maximum Version Setting:
  1. Stop the DOORS client.

  2. If you don't have another DOORS 9.3 database, create one. Review Tech Note #1656872 for instructions.

  3. Connect the DOORS 9.3 client to your new database. If this works, you have isolated the problem to one specific DOORS database.

    If you have one database that works, and one that does not, try the following workaround:

    WORKAROUND:
    1. Stop both DOORS Database Servers.

    2. In the database having the problem, rename the server_settings.dtc file to server_settings.dtc.orig.

    3. Make a copy of the new database's server_settings.dtc file.

    4. Place the copy of server_settings.dtc you made in the correct location of the other database, and rename it to server_settings.dtc.

    5. Start the DOORS database that was having the problem.

    6. Attempt to connect with the DOORS 9.3 client -- if this works, you have successfully isolated the issue to the problem database's original server_settings.dtc file. Please contact Support and provide a copy of the problematic server_settings.dtc file for analysis. The server_settings.dtc file is an encrypted file that contains DOORS database configuration settings.

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Document Information

Modified date:
01 May 2020

UID

swg21452570