IBM Support

Search rules are not working in WebSphere Commerce when HTTPS is enforced on the web server

Troubleshooting


Problem

Attempts to configure and test search rules in WebSphere Commerce fail. Tracing reveals the following message: Querying search rules failed with the following error "Service request...".

Cause

Commerce web server was configured to redirect all traffic to HTTPS. When the Search server tries to connect to it, its' request is redirected and that is not supported.

Diagnosing The Problem

Full message with foundation tracing enabled on the Search server:

[7/17/17 20:42:39:306 GMT] 000000cb SolrRESTSearc 1
com.ibm.commerce.foundation.server.services.rest.search.expression.solr.
SolrRESTSearchBasedMerchandisingExpressionProvider
failedQueryingTermsWithSearchRules() Querying search rules failed with
the following error Service request
'http://localhost/wcs/resources/store/10151/espot' resulted in the
following exception: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a
href="https://localhost/wcs/resources/store/10151/espot?q=allSearchTerms">her…;
<hr>
<address>IBM_HTTP_Server at localhost Port 80</address>
</body></html>

Resolving The Problem

Modify configuration to stop redirecting all traffic to HTTPS, and use struts config. to force HTTPS for URLs as needed.

[{"Product":{"code":"SSWT7D","label":"Commerce on Cloud"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB31","label":"WCE Watson Marketing and Commerce"}}]

Document Information

Modified date:
16 June 2018

UID

swg22006424