Troubleshooting
Problem
In Cognos Business Intelligence, even if the reports are scheduled for future dates, their schedule is not shown in 'View Future Activities' screen for all the users.
Symptom
Cognos Administration->Status-> Upcoming Activities -> Select any date, which you are sure it does contain schedule but still it does not show up.
Cause
Corruption in the data present in NC tables.
Resolving The Problem
Dropping the NC tables that use the NC_DROP_<Database>.sql script resolves the issue.
Note: - If you have configured a notification database, then you must follow these steps in the notification database and not in the content store. So whatever steps are mentioned for content store needs to be done for Notification database
The following are the steps for dropping the NC tables:
1- Stop Cognos Service
2- Have the Database Administrator back up the Complete Cognos content store database.
3- Connect to content store database using a database tool and with the same login as provided for Content store in Cognos configuration run the NC_DROP script found in the appropriate location depending on the database on which your content store is:
<Install Location>\configuration\schemas\delivery\oracle\NC_DROP_ORA.sql
<Install Location>\configuration\schemas\delivery\db2\NC_DROP_DB2.sql
<Install Location>\configuration\schemas\delivery\sqlserver\NC_DROP_MS.sql
You should not receive any error message in the script that you execute.
4- Start the Cognos service from within Cognos Configuration. This will recreate all the NC tables.
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Document Information
Modified date:
15 June 2018
UID
swg21429773