IBM Support

S-GATE functionality preventing SQL Server cluster from starting

Troubleshooting


Problem

S-GATE functionality preventing SQL Server cluster from starting

Cause

This has been identified as a product defect under APAR GA15636

Diagnosing The Problem

Intermittent problems can occur when starting a SQL Server cluster that contains servers with S-TAPs using the S-GATE blocking functionality.

To identify if S-GATE blocking functionality with firewall closed mode is configured in the environment, look for the following settings enabled in the STAP ini file:
firewall_installed = 1
firewall_timeout = 10
firewall_fail_close = 1
firewall_default_state = 1


Furthermore, check system logs for a similar '1032 (0xfffffbf8)' error occurrences during the startup failure as given in the example below:

Example errors found in the Windows Application Event log:

sqlservr (8324) Error -1032
(0xfffffbf8) occurred while opening logfile C:
\Windows\system32\LogFiles\Sum\Api.log.


or

Windows System Event Log:


The SQL Server (Server_Name) service
terminated unexpectedly.

Resolving The Problem

This could happen when firewall closed mode is used and monitoring clustered MS SQL Server.

The possible defect was found in v10.1.23.60 (V10.1.2), and V10.2.30.1 (V10.1.3).

[NOTE] This is not a crash issue.

LOCAL FIX:
Fixed in Guardium v10.1.3 Windows STAP 10.2.30.12

Fix Completion Date: 2017-09-22

Filename: Guardium_STAP_Windows_v10.2.30.12.zip

MD5Sum:f7d956e833f278a128f388b479f89830

Please download Windows S-Tap v10.2.30.12 or above and apply.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium S-TAP","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.3","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22009352