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Running RTAM raises event on all availability changes

Troubleshooting


Problem

Running Real Time Availability Monitor(RTAM) agent triggers the configured event for all availability changes in IBM Sterling Selling and Fulfillment Suite

Symptom

Steps to reproduce:

  1. Set Activity based RTAM is configured to raise event whenever availability changes beyond the threshold.

  2. Set upper threshold is set as 10.

    Now, when availability goes beyond the threshold, the event is triggered as expected. However, even if availability now changes for 20 > 30 the event gets re-triggered. This is not as per expectation.

Cause

The unexpected behavior is due to configuration for RTAM agent where RaiseEventOnAllAvailabilityChanges is set to Y.

Diagnosing The Problem

When RTAM is configured to raise events based on the specified thresholds, the events get triggered only when the change crosses the configured threshold and not on all availability changes. The event is raised on all availability changes regardless of whether availability exceeds or falls below specified thresholds.

Resolving The Problem

Set RaiseEventOnAllAvailabilityChanges to N for the RTAM agent to ensure that event gets raised only on crossing the thresholds,

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Document Information

Modified date:
10 May 2022

UID

swg21667836