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Running report after Cognos version upgrade throws error "error.Exception occurred: java.lang.IndexOutOfBoundsException".

Troubleshooting


Problem

While running report after upgrade of Cognos version results into error "error.Exception occurred: java.lang.IndexOutOfBoundsException".
Opening the same report in Report Studio also throws same error.

Cause

JDBC driver version on Cognos and DB2 database version incompatible with each other.

Environment

Cognos BI 10.2.2
DB2

Resolving The Problem

1. Ensure correct JDBC drivers (db2jcc4.jar and db2jcc_license_cu.jar) are copied from DB2 server installation\SQLLIB\JAVA directory to <Cognos installation directory>\v5dataserver\lib and <Cognos installation directory>\webapps\p2pd\WEB-INF\lib . Restart of Cognos service is needed after copying of JDBC drivers.
2. Execute command java -cp ./db2jcc4.jar com.ibm.db2.jcc.DB2Jcc -version under <Cognos installation directory>\v5dataserver\lib and <Cognos installation directory>\webapps\p2pd\WEB-INF\lib directories. Output should show the version of JDBC driver. This version of JDBC driver and database should be compatible with each other.
Refer to https://www.ibm.com/support/pages/db2-jdbc-driver-versions-and-downloads to ensure correctness.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.2.1, 10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
30 March 2020

UID

ibm16129501