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Running the payment agent after creating returns in a Appeasement Case moves the Payment Status to Await Payment information Sterling Selling and Fulfillment Suite

Troubleshooting


Problem

Attempts to run the payment agents after creating returns in a Appeasement Case causes the order's Payment Status to move to Await Payment information in IBM Sterling Selling and Fulfillment Suite.

Symptom

Steps to reproduce:

  1. Order created with single Order Line of 100$.

  2. Run processOrderPayments API on the order.

  3. Schedule , release, ship and invoice the order
    The payment status after triggering the Payment agent is Paid. Amount collected shows as 100$.

  4. Create a credit Memo invoice for 100$.
    Collected amount went to zero post step 3.

  5. Create return for the sales order and invoice the order.

  6. Run the payment agents
    The payment status of the Sales Order move to Await Payment Information.

Cause

The payment method is configured incorrectly.

Resolving The Problem

Enable the flag Refund to exceed charge amount in financial rule.
As there is a refund more than the order total EXCEED_CHARGE_AMOUNT_FOR_REFUND should be enabled so that amount could be refunded to the payment method added on the order.

Related Information

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"Distributed Order Management","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.2.1;9.2;9.1;9.0","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21661682