Troubleshooting
Problem
When you install IBM Rational DOORS Web Access 1.4.0.4 on the same server as DOORS 9.3.0.5, you need Interoperation Server 9.3.0.4. On Microsoft Windows, this results in one system with different versions of the DOORS client and server, which may cause problems. This issue applies to later versions of DOORS as well.
Symptom
When the IBM Rational DOORS client and DOORS server have different fix pack versions but are both installed to the default location, you may encounter unexpected behavior like:
- Rational DOORS Web Access (DWA) being unresponsive
- DOORS dbadmin command not working correctly
- DWA Interoperation Server not working correctly
- The DOORS server will work fine, but the DOORS client installed on the DOORS server system will fail to start, and you may get errors complaining about not finding a necessary entry point or locating a needed dynamic link library (DLL).
Cause
When the IBM Rational DOORS client and DOORS server have different fix pack versions but are both installed to the default location, some of the binary files overwrite each other, and they may conflict because of the different fix pack versions. This problem does not occur if both the DOORS client and the DOORS server are at the same fix pack version.
Environment
This has been seen on Microsoft Windows systems where the IBM Rational DOORS client and DOORS server have different fix pack versions but are both installed to the default location on the same machine.
Diagnosing The Problem
Launch the IBM Rational DOORS client and run the Help -> About command. If the client version and the server version are slightly different, and you installed both to the default location, you may have problems from conflicting binaries.
Resolving The Problem
There are two ways to resolve this issue:
- Use Custom installations to install the DOORS client and DOORS server to different locations.
- Use the same fix pack version for the DOORS client and DOORS server, when installing components on the same machine, if you want to use the Typical installation.
If you are already having this problem, you should schedule downtime and then:
- Stop DOORS.
- Uninstall the DOORS server (this does not remove your database).
- Uninstall the DOORS client.
- Reinstall the DOORS client and the DOORS server as described above.
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Document Information
Modified date:
01 May 2020
UID
swg21573528