IBM Support

Running a DQM report in Cognos Analytics fails: "XQE-GEN-0010 Found an internal error: '!mapSuccess"

Troubleshooting


Problem

Running a DQM report in Cognos Analytics fails: XQE-GEN-0010 Found an internal error: '!mapSuccess - reportName=Report - edgeName=29 - edgeOrdinal=1 - tuple=([TBdimension_5].[TBhierarchy_5].[all].[2010].[].[]).'.

Cause

Nulls are suppressed for the report query.

Resolving The Problem

Disabling null suppression for the report query can be used to work around this issue.

Steps:

  1. Open Cognos Analytics in a browser.
  2. Open the failing report in 'Edit mode'.
  3. Click on the ‘Queries’ icon in the left side panel.
  4. Select the query under the ‘QUERIES’ option and click on the ‘Properties’ icon in the top right hand corner of the screen.
  5. Click on the ‘Suppress’ option under ‘QUERY HINTS’ and set the value to ‘None’.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22013902