Troubleshooting
Problem
Attempts to run RTAM agent throws the ErrorReason="PLT0602" ErrorType="NONREPROCESS" ExceptionType="UIEXCEPTION" in IBM Sterling Order Management 9.5.
Symptom
Steps to reproduce:
- Upgrade Sterling Order Management to 9.5.
- Real Time Availability Monitor (RTAM) agent
The below error is seen during the agent start-up.
<Inbox ActiveFlag="Y" ApiName="monitorItemAvailability" Consolidate="Y" ConsolidationWindow="DAY" ErrorReason="PLT0602" ErrorType="NONREPROCESS" ExpirationDays="7" QueueKey="">
Cause
The version number of the product label Sterling Selling and Fulfillment Suite still refers to the previous version
Diagnosing The Problem
The stack trace shows failure occurring during version validation:
com.yantra.yfc.util.YFCException at com.yantra.yfc.dblayer.YFCEntity.validateFeatureVersion(YFCEntity.java:734)
at com.yantra.yfc.dblayer.YFCEntityDBHome.validateFeatureVersion(YFCEntityDBHome.java:5308) at com.yantra.shared.dbclasses.YFS_Inventory_AlertsDBHome.setValuesOnInsertPreparedStatement(YFS_Inventory_AlertsDBHome.java:1652)
at com.yantra.yfc.dblayer.YFCEntityDBHome.internal_addToBatchForInsert(YFCEntityDBHome.java:4750)
at com.yantra.yfc.dblayer.YFCEntityDBHome.addToBatchForInsert(YFCEntityDBHome.java:4690)
Resolving The Problem
To resolve, Invoke the following script
> {runtime}/bin/ fullRollOutDataMigration.cmd/sh.
The script is executed from the base version.
For example, if you deploy two versions 9.3 and 9.4, and set 9.3 as the base version and 9.4 in staged mode, when the 9.3 version is ready to be removed, execute the script from 9.4 runtime. The script updates the SI_VERSION table, and makes it the base version in the entire deployment to 9.4.
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Document Information
Modified date:
16 June 2018
UID
swg21998706