Troubleshooting
Problem
Validating or running a report displays the following
Symptom
Error Message:
RSV-SRV-0003 The report specification contains an error at line '<line>', column '<col>'.
Cause
The report specification contains invalid information. In new releases, the tendency has been that validation has become stricter, so this message can appear on a report that worked in a previous release.
Environment
IBM Cognos Busines Intelligence - Report Studio
Resolving The Problem
The error usually indicates a formal error in XML or a tag being used that is unknown to the version that is used. Ie. in 10.2.2 a reportname tag was introduced which is unknown to previous versions.
If you know the latest changes, revert them back and verify if the error goes away.
Steps:
- Get the report specification in Report Studio by clicking Tools->Copy report to clipboard, then pasting into a text editor. Make sure line wrapping is not enabled so the line numbers will be correct
- Move to the specified line and column numbers to find out what the offending element is.
- Fix the problem element, if possible
- Copy the entire report specification and then in Report Studio: Tools->Open report from clipboard, to use the updated report specs.
Troubleshooting
Usually the detailed message after the RSV-SRV-0003 message can help solve the problem.
E.g. RSV-SRV-0003 The report specification contains an error at line '<line>', column '<col>'.
Detailed message: "Datatype error: Type:InvalidDatatypeFacetException, Message: Value '0' must be greater than or equal to MinInclusive '1'."
Looking at the report specs at line <line> and column <col>, the problem tag was:
<pageset ... resetPageCount="0">
The gist of the message indicates that "Value '0' must be...greater than or equal to ... '1'".
Changing the resetPageCount="0" to resetPageCount="1" resolved the issue. An alternative would have been to change the Pagination property of the Page Set from 0 to 1 in Report Studio.
If you cannot find any obvious errors, save the reportspecification as *.xml and open in a browser, to verify the correctness of the xml format (ie. number of closing tags matches number of open tags).
Note:
The above solution only works when the error message refers to the full report specification. This error message has also been seen on "sub-reports" - for instance, viewing Tabular Data. The report server generates its own report specs for these. This means that you will not have access to these specs, so the above troubleshooting method will not work.
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Document Information
More support for:
Cognos Business Intelligence
Software version:
10.2.2, 10.2.1, 10.2
Operating system(s):
Windows
Document number:
369785
Modified date:
15 June 2018
UID
swg21341763