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Resolving missing DLL files during client-to-server SSL configuration

Troubleshooting


Problem

During client SSL configuration gsk8capicmd and gsk8capicmd_64.exe may return a system error for missing DLL files

Symptom

When attempting to run gsk8capicmd_64.exe a message is received with a system error:

"The program can't start because <GSK8_DLL_NAME>.DLL is missing from your computer. Try reinstalling the program to fix this problem."


Cause

In the screen shot example illustrated above this is caused due to the fact that the GSK8 directory paths were defined using "double quotes". Double quotes should not be used when defining a directory path. When double quotes are used the program does not search the desired directory within the quotes, but includes the quotes as part of the path. This results in the system error stating the DLL files are missing.

Environment

All supported Windows environments

Diagnosing The Problem

The problem can be diagnosed by reviewing the PATH definitions within the command prompt either by typing in "path" or "set" which will return the values specified for the PATH variable. Ensure that double quotes are not used in any of the GSK8 directories specified and confirm the DLLs do in fact exist in the path directory that was defined.

Resolving The Problem

The problem can be resolved by simply defining the correct PATH directory without the double quotes. It will be necessary to ensure the path is correct and that the DLL files mentioned in the Windows system error do in fact exist in the "...\gsk8\lib64" directory.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21959375