IBM Support

Resolving Integrity Checker error BMXAA0433E

Troubleshooting


Problem

Integrity Checker reports error:
BMXAA0433E -- The security-group-related data for the group name EVERYPLACE could not be deleted. Try the operation again, or delete the security-group-related data manually.

Symptom

This error occurs in repair mode only, and follows this error:

BMXAA0443E -- Error - BMXAA0458E -- The following user groups were not found in the MAXGROUPS table. Run the Integrity Checker in repair mode.
BMXAA6837I - User: EVERYPLACE Group: EVERYPLACE

Cause

Integrity Checker reports error
BMXAA0443E -- Error - BMXAA0458E -- The following user groups were not found in the MAXGROUPS table. Run the Integrity Checker in repair mode.
BMXAA6837I - User: EVERYPLACE Group: EVERYPLACE


If you run repair mode as suggested, it attempts to resolve this error. During the repair process, Integrity Checker encounters another error BMXAA0433E -- The security-group-related data for the group name EVERYPLACE could not be deleted. Try the operation again, or delete the security-group-related data manually.

The group specified in error BMXAA0458E is dropped from Maximo tables MaxGroup, GroupUser, AppFieldDefaults, ApplicationAuth, and Tolerance. The problem is that Tolerance is a legacy table that was removed from Maximo at release 6.2. But the reference to the table was not removed from Integrity Checker. Because table Tolerance does not exist, the delete fails, and error BMXAA0433E is reported.

Diagnosing The Problem

Integrity Checker attempts to resolve error BMXAA0458E with this SQL statement:

Delete From tolerance Where username = '<group>' ;

If you run this SQL statement manually, replacing <group> with the group specified in error BMXAA0448E, the statement will fail because table Tolerance does not exist.

Resolving The Problem

No resolution is necessary. Prior to the error, the specified group, in this case 'EVERYPLACE', was removed form the other Maximo security tables MaxGroup, GroupUser, AppFieldDefaults, and ApplicationAuth. As such, the group was successfully removed from the security tables. If you now run Integrity Checker again, the error will not be reported.

[{"Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"ARM Category":[{"code":"a8m50000000CbDAAA0","label":"Upgrade-\u003EIntegrity Checker"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.6.0;7.6.1","Type":"MASTER"},{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSWT9A","label":"IBM Control Desk"},"ARM Category":[{"code":"a8m500000008b3TAAQ","label":"Miscellaneous Category (Portal, UI, Maximo, Install)"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.6.0;7.6.1"},{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m50000000CbDAAA0","label":"Upgrade-\u003EIntegrity Checker"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
22 May 2024

UID

swg21966049