Troubleshooting
Problem
Customer can find issues with batch jobs unlessthe 'Client Distribution Server' settings are filled in (and the Batch service is started using the Controller Configuration GUI).
Symptom
If the instructions in this Technote are not performed, then issues can occur.
- For example, see separate IBM Technote #886589.
Cause
From Controller version 10.4.0 onwards, there is a new requirement to change the value of "WSSUrl" inside the file CCRBatch.exe.config.
- For more details, see official documentation (link below).
More Information:
After Controller server software has been installed, the CCRBatch.exe.config file (default location here: C:\Program Files\ibm\cognos\ccr_64\server) contains the following value:
![image 3120](/support/pages/system/files/inline-images/image_3120.png)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
<add key="WSSUrl" value="http://localhost:1969" />
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
However, for the batch service system to work, it needs to be changed to a valid value, for example something similar to:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
<add key="WSSUrl" value="http://myservername.mycompany.com/ibmcognos/controllerserver" />
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Environment
Versions of Controller from 10.4.0 onwards, for example:
- Controller 10.4.0
- Controller 10.4.1
- Controller 10.4.2
Resolving The Problem
Perform the following steps on the Controller application server:
1. Launch Controller Configuration
2. Open section 'Client Distribution Server Config'
3. Enter the correct value for WSSUrl, for example: http://myservername.mycompany.com/ibmcognos/controllerserver
![image 3046](/support/pages/system/files/inline-images/image_3046.png)
Optional: At this stage you can also fill in the other settings (for example SelectDb, Language) to look similar to the example above.
4. Press 'Save'
5. Open section 'Batch Services'
6. If the button is available. click Stop
7. Click the button Start
![image 3047](/support/pages/system/files/inline-images/image_3047.png)
VITAL: You MUST perform this task (at least once) using the Controller Configuration GUI
- If you start the service via the 'Windows Services' GUI then the file 'CCRBatch.exe.config' will not be correctly updated.
8. Test.
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000brYKAAY","label":"Installation"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
30 April 2020
UID
ibm16199107