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The requested path does not exist error is received while attempting to log in to TM1 Contributor

Troubleshooting


Problem

The requested path does not exist error is received while attempting to log in to TM1 Contributor

Symptom

  • Logins over other components such as Planning Analytics Spreadsheet Services, Workspace etc. work as expected.
  • Issue is experienced only when Contributor is configured to use CAM authentication. Logins work as expected while using TM1 native authentication.

Cause

Issue is likely triggered due to missing bi interop files over Cognos Analytics servers or the files being corrupted.

Resolving The Problem

  • Copy over the current tm1web.html, planning.html and pmhub.html files (refer location details below) to an alternative location.
  • Copy bi_interop.zip folder (refer location details below) from the TM1 Server.
  • Extract bi_interop.zip and copy/merge the content to the analytics folder on the Cognos Analytics server.
  • Restore the tm1web.html, planning.html and pmhub.html file from backup taken in step 1 and test logins.
Locations
  • bi_interop.zip: \ibm\cognos\tm1_64\bi_interop
  • tm1web.html: \ibm\cognos\analytics\webcontent\tm1\web and \ibm\cognos\analytics\webcontent\bi\tm1\web
  • planning.html: \ibm\cognos\analytics\webcontent and \ibm\cognos\analytics\webcontent\bi
  • pmhub.html: \ibm\cognos\analytics\webcontent and \ibm\cognos\analytics\webcontent\bi

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m50000000KzJeAAK","label":"Security->CAM (Business Intelligence, Cognos Analytics)"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
12 October 2021

UID

ibm16498437