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"The request failed with HTTP status 503: The service is unavailable" when launching Controller

Troubleshooting


Problem

User launches Controller. User receives an error.
 
If user launches the Cognos Connection website (http://servername/ibmcognos) then a similar error appears.

Symptom

Example #1 - Controller 10.1.1 on Windows 2008 R2

  • The request failed with HTTP status 503: The service is unavailable.
 

Message when launch Cognos Connection website:


Service Unavailable
--------------------------------------------------------------------------------
HTTP Error 503. The service is unavailable.
 
Example #2 - Controller 10.2.0

The request failed with HTTP status 503: Service Unavailable.

Cause

The application pool (which is running the Cognos-related services) has a problem.
 
Example #1
In one real-life example, the application pool was stopped:


Example #2
In one real-life example, the application pool was configured to run under an Active Directory Windows user account, that had a problem (for example the password had been changed/expired, so it was locked out).

Resolving The Problem

Fix the problem with the IIS (webserver) application pool.

 

Example #1

Start the relevant application pool:

 

Example #2

Reconfigure the relevant application pool to run under the account "LocalSystem".

Steps:

1. Right-click on the application pool which is running Controller.

  • Example: By default, for Controller 10.2.0 this is: .NET 2.0
2. Choose "Advanced Settings"

3. Change the 'Identity' setting to be LocalSystem:

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0;10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
21 July 2020

UID

swg21993066