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"The request failed with HTTP status 503: The service is unavailable" when launching Cognos via IIS gateway

Troubleshooting


Problem

User launches Cognos Analytics portal, via the IIS gateway (http://servername/ibmcognos). An error appears.

Symptom

Service unavailable
Service Unavailable
HTTP Error 503: The service is unavailable

Cause

The application pool (which is running the Cognos-related services) has a problem.
The application pool stops as soon as the Cognos Analytics IIS gateway is launched:Screenshot of application pool

Environment

Windows environment

Diagnosing The Problem

Review the Windows event viewer.
 
Example:

In one real-life example, the Windows Event Viewer showed the error below:

The Module DLL C:\Windows\system32\inetsrv\rewrite.dll failed to load. The data is the error.

Resolving The Problem

In one real-life example, the solution was:
1. Launch Windows Update and apply all available Microsoft updates
2. Run the Cognos Analytics "IIS configuration script".

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
18 August 2020

UID

ibm10885372