IBM Support

Report views get broken when replacing a report: Source report unavailable

Troubleshooting


Problem

After replacing a report, links to report views that refer to the report are lost (broken link icon in Cognos Connection; report view properties: 'Source report unavailable').

Cause

Every 'save as' operation in Report Studio changes the report ID.

Resolving The Problem

  1. When working on the original report: Use only 'save', not 'save as'.
  2. When working on a copy of the original report: Use copy&paste in Cognos Connection in order to retain the report ID and the link to the report views.

Steps:

  1. Save the Report using 'save' in Report Studio (NOT 'save as').
  2. Use copy&paste in Cognos Connection in order to replace the previous report version. Confirm the following message with 'yes': 'A name conflict was detected. The name [...] conflicts with an existing object name under the parent object /... Would you like to replace the existing entry and all other conflicting entries that exist in that location?'

This behaviour has been changed since Cognos BI 10.2, and now requires additional configuration. Please Related Information section for details.

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Document Information

Modified date:
15 June 2018

UID

swg21382369