Troubleshooting
Problem
A specific report cannot be executed because of dispatcher communication errors.
Symptom
The user sees:
CAF-WRN-2082 An error has occurred. Please contact your administrator.
The complete error has been logged by CAF with SecureErrorID: <...>
The log file shows:
DPR-ERR-2072 Unable to load balance a request with absolute affinity, most likely due to a failure to connect to the remote dispatcher. See the remote dispatcher detailed logs for more information. Check the health status of the installed system by using the dispatcher diagnostics URIs.
Handler trace back: [the_dispatcher]
com.cognos.pogo.handlers.performance.PerformanceIndicationHandler
[the_dispatcher] com.cognos.pogo.handlers.logic.ChainHandler
[service_lookup] com.cognos.pogo.handlers.engine.ServiceLookupHandler
[load_balancer] com.cognos.pogo.handlers.logic.ChainHandler
[lb_forwarder] com.cognos.p2plb.clerver.LoadBalanceHandler
CAF-WRN-2082 An error has occurred. Please contact your administrator.
The complete error has been logged by CAF with SecureErrorID: <...>
The log file shows:
DPR-ERR-2072 Unable to load balance a request with absolute affinity, most likely due to a failure to connect to the remote dispatcher. See the remote dispatcher detailed logs for more information. Check the health status of the installed system by using the dispatcher diagnostics URIs.
Handler trace back: [the_dispatcher]
com.cognos.pogo.handlers.performance.PerformanceIndicationHandler
[the_dispatcher] com.cognos.pogo.handlers.logic.ChainHandler
[service_lookup] com.cognos.pogo.handlers.engine.ServiceLookupHandler
[load_balancer] com.cognos.pogo.handlers.logic.ChainHandler
[lb_forwarder] com.cognos.p2plb.clerver.LoadBalanceHandler
Cause
Inconsistent Cognos Application Firewall (CAF) configuration.
Some instances have CAF enabled, another disabled.
Some instances have CAF enabled, another disabled.
Environment
Distributed installation of IBM Cognos Analytics components (v11.0.5)
Here we have 2 App tiers, 1 Content Manager, 1 Gateway on Linux Ubuntu 14.0.4 and Windows Server 2012.
Here we have 2 App tiers, 1 Content Manager, 1 Gateway on Linux Ubuntu 14.0.4 and Windows Server 2012.
Diagnosing The Problem
To get CAF details on the error check the cogserver.log of all app tiers to start your researches on possible reasons.
Communication errors are either caused by mis-configuration, the cogstartup.xml files of all instances are relevant.
Otherwise network connections, firewalls etc. could play a role, which were not relevant in this case.
Communication errors are either caused by mis-configuration, the cogstartup.xml files of all instances are relevant.
Otherwise network connections, firewalls etc. could play a role, which were not relevant in this case.
Resolving The Problem
Configuration mismatch found for CAF: Ensure CAF is enabled on all instances (or else that CAF is disabled on all instances).
Adjust IBM Cognos Configuration.
Save your configuration and restart the instance: If it's your content manager instance, stop others first, otherwise just the instance from which configuration was changed.
Adjust IBM Cognos Configuration.
Save your configuration and restart the instance: If it's your content manager instance, stop others first, otherwise just the instance from which configuration was changed.
[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
28 October 2021
UID
swg22002992