Troubleshooting
Problem
Recent File Transfer Activity widget in IBM Control Center Dashboard is not populated with the number of file transfers from Sterling B2B Integrator.
Symptom
- No error messages on both sides.
- At the Sterling B2B Integrator side, with cccinterop.log in verbose mode, we can see messages as below , showing that the visibility fetched records is always 0 rows:
[2017-05-24 15:32:46.054] DEBUG cccinterop.History- leaving handleRequest(). Rows fetched : 0
- At IBM Control Center side, with trace enabled for the Sterling B2B Integrator server, you can see messages as below in Engine_<timestamp>.log, showing that the number of visibility records retrieved is always 0:
25 May 2017 10:06:07,386 1524185 [AftDataTaskTimer] DEBUG <SI_ServerName> - com.sterlingcommerce.scc.agent.services.node.gis.AftHistoryHandler.getHistory() getResults returned this many records - 0
Cause
Sterling B2B Integrator is not storing visibility data. It has one of the following properties:
- in customer_overrides.properties:
dmivisibility.visibility_coverage=None
OR
- in visibility.properties:
visibility_coverage=None
Resolving The Problem
Is up to Sterling B2B Integrator Administrator to decide if they will enable the storage of visibility data. Having visibility_coverage=None is the best for Sterling B2B Integrator performance but decreases the visibility. The key is the balance between “Performance vs. Visibility”:
- High visibility comes at a cost to performance
- High performance comes at a cost to visibility
visibility_coverage=CommBase is the lowest level of visibility_coverage that will allow IBM Control Center to populate Recent File Transfer Activity widget.
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Document Information
Modified date:
17 December 2019
UID
swg22004019