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Readme for collecting perfpmr

Question & Answer


Question

How to collect perfpmr on AIX 7.1

Cause

Performance issues found in AIX 7.1 . Diagnostic data requested for problem resolution.

Answer

This perfpmr package contains a number of performance tools and some instructions.  Some of these tools are products available with AIX.  Some of the tools are prototype internal tools (setpri, setsched, iomon, getevars, pmucount, lsc, fcstat2, memfill, getdate, perfstat_trigger, kheap, tcpstat, foldstat, tstat, pvpa) and are not generally available to customers.  Anyone who downloads or uses these tools must agree to these terms:
These tools are not officially supported and are provided "AS IS".
In addition, tools such as pmucount and pmucount.sh should not be used unless directed to do so by IBM level 3 performance
support.

NO WARRANTY FOR THE PROGRAM, THE PROGRAM'S RESULTS, OR INFORMATION CONTAINED IN THE PROGRAM
You are responsible for the results obtained from the use of the Program. Any results of the Program are provided "AS IS".
All results generated by the Program are estimates and averages based on certain assumptions and conditions. Each environment has its own unique set of requirements that no tool can entirely account for. No representation is made that the results will be accurate or achieved in any given IBM installation environment. The result is based on specific configurations and run time environments. Customer results will vary. Any configuration recommended by the Program should be tested and verified. Any code provided is for illustrative purposes only.
IBM does not warrant the accuracy, currency or completeness of information contained in the Program, including, but not limited to any information provided to IBM by any third party, and undertakes no obligation to correct or update such information. Any reliance by You on the Program or any results from the Program, including any information from any third party, is at Your sole risk and will not create any liability or obligation for IBM. IBM provides no assurances that any reported problems may be resolved with the use of any information that IBM provides.
Further, IBM does not control the transfer of data over the Internet. IBM does not warrant secure operation of the Program. In addition, IBM does not warrant that it will be able to prevent third party disruptions of the Program.
---------------------------------------------------------

AIX 7.1 PERFORMANCE DATA COLLECTION PROCESS
---------------------------------------------------------

 Note:   The act of collecting performance data will
         add load on the system.  HACMP users may
         want to extend the Dead Man Switch timeout
         or shutdown HACMP prior to collecting perfpmr data
         to avoid accidental failovers.


 TABLE OF CONTENTS
 -----------------
      I.   INTRODUCTION

     II.   HOW TO OBTAIN AND INSTALL THE TOOLS ON AN IBM RISC SYSTEM/6000.

    III.   HOW TO COLLECT DATA FOR AN AIX PERFORMANCE PROBLEM

     IV.   HOW TO SEND DATA TO IBM





I.   INTRODUCTION

     This package contains a set of tools and instructions for
     collecting the data needed to analyze a AIX performance
     problem.  This tool set runs on AIX V7.1


II.  HOW TO OBTAIN AND INSTALL THE TOOLS ON AN IBM RISC SYSTEM/6000.


     A. OBTAINING THE PACKAGE

          The package will be distributed as a compressed
          "tar" file available electronically.

           From the internet:
           ==================
           'ftp://ftp.software.ibm.com/aix/tools/perftools/perfpmr'




     B. INSTALLING THE PACKAGE

          The following assumes the tar file is in /tmp and named
          'perf71.tar.Z'.

          a. login as root or use the 'su' command to obtain root
             authority

          b. create perf71 directory and move to that directory (this
             example assumes the directory built is under /tmp)

             # mkdir /tmp/perf71
             # cd /tmp/perf71


          c. extract the shell scripts out of the compressed
               tar file:

             # zcat /tmp/perf71.tar.Z | tar -xvf -




III. HOW TO COLLECT DATA FOR AN AIX PERFORMANCE PROBLEM


     A. Purpose:

          1. This section describes the set of steps that should be
             followed to collect performance data.

          2. The goal is to collect a good base of information that
             can be used by AIX technical support specialists or
             development lab programmers to get started in analyzing
             and solving the performance problem. This process may
             need to be repeated after analysis of the initial set
             of data is completed.


     B. Collection of the Performance Data on Your System

          1. Detailed System Performance Data:

             Detailed performance data is required to analyze and
             solve a performance problem. Follow these steps to
             invoke the supplied shell scripts:

             NOTE:  You must have root user authority when executing
             these shell scripts.


               a. Create a data collection directory and 'cd' into this
                  directory.
                  Allow at least 45MB*#of_logicalcpus of unused space in
                  whatever file system is used.


                  *IMPORTANT* - DO NOT COLLECT DATA IN A REMOTELY MOUNTED
                  FILESYSTEM SINCE IPTRACE MAY HANG

                  For example using /tmp filesystem:
                      # mkdir /tmp/perfdata
                      # cd /tmp/perfdata

               b. HACMP users:
                    Generaly recommend HACMP deadman switch interval
                    be lengthened while performance data is being
                    collected.

               c. Collect our 'standard' PERF71 data for 600 seconds
                   (600 seconds = 10 minutes).  Start the data collection
                   while the problem is already occurring with the command:

                    /directory_where_perfpmrscripts_are_installed/perfpmr.sh

                  The perfpmr.sh shell provided will:
                  - immediately collect a 5 second trace (trace.sh 5)
                  - collect 600 seconds of general system performance
                     data (monitor.sh 600).
                  - collect hardware and software configuration
                     information (config.sh).

                  In addition, if it finds the following programs available
                  in the current execution path, it will:
                  - collect 10 seconds of iptrace information (iptrace.sh 10)
                  - collect 10 seconds of filemon information (filemon.sh 10)
                  - collect 60 seconds of tprof information (tprof.sh 60)

                  NOTE:
                  Since performance problems may mask other
                  problems, it is not uncommon to fix one issue and
                  then collect more data to work on another issue.

               d. Answer the questions in the text file called
                   'PROBLEM.INFO' in the data collection directory
                   created above.  This background information
                   about your problem helps us better understand
                   what is going wrong.


IV. HOW TO SEND THE DATA TO IBM.

     A. Combine all the collected data into a single binary 'tar' file
         and compress it:

          Put the completed PROBLEM.INFO in the same directory
          where the data was collected (ie. /tmp/perfdata in
          the following example).  Change to the parent
          directory, and use the tar command as follows:

   Either use: cd /tmp; perfpmr.sh -o perfdata -z pmr#.pax.gz
   or
          # cd /tmp/perfdata   (or whatever directory used
                                 to collect the data)
          # cd ..
   # pax -xpax -vw perfdata | gzip -c > pmr#.pax.gz


     B. Submission of testcase to IBM:

          Internet 'ftp' access:
          ----------------------
            The quickest method to get the data analyzed is
            for the customer to ftp the data directly to IBM.
            Data placed on the server listed below cannot be
            accessed by unauthorized personnel.
            Please contact your IBM representative for the
            PMR#, BRANCH#, and COUNTRY#.  IBM uses all 3 to
            uniquely associate your data with your
            problem tracking record.

              'ftp testcase.software.ibm.com'
               Userid:  anonymous
               password:  your_internet_email_address
                          (ie. smith@austin.ibm.com)
              'cd toibm/aix'
              'bin'
              'put  PMR#.BRANCH#.COUNTRY#.pax.gz'
                 (ie. '16443.060.000.pax.gz'
              'quit'

           If the transfer fails with an error, it's possible that a file already exists by the same name
           on the ftp server. In this case, add something to the name of the file to differentiate it from the file
           already on the ftp site (ex. 16443.060.000.july18.pax.gz).

            Notify your IBM customer representative you have
            submitted the data.  They will then update the
            defect report to indicate the data is available
            for analysis.



             This data will then be transferred electronically
             to AIX Development by 'ftp'.
             IBM Software Service in the geography should inform
             the Austin AIX Support Center when the performance
             data has been sent to Austin by updating the PMR.

               'ftp' address:
                     testcase.software.ibm.com

                 (use the procedure for internet ftp access described above)

Related Information

[{"Product":{"code":"SWG10","label":"AIX"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

Modified date:
15 September 2021

UID

isg3T1026140