Troubleshooting
Problem
A user might experience performance issues after signing into Architect or Perspectives within a remote session.
For example, the user is likely to notice that it takes anywhere between 3-5 minutes for objects (cubes, dimensions, processes) to finally appear.
Symptom
Architect or Perspectives might go into a nonresponsive state at times.
Cause
The issue is caused by the Windows service process titled "Touch Keyboard and Handwriting Panel".
Diagnosing The Problem
Confirm that the "Touch Keyboard and Handwriting Panel" process is present in the Task Manager (see Figure 1).
Figure 1 - Touch Keyboard processes within the Task Manager
Resolving The Problem
After further testing, and confirmation from several RDP related online forums, this particular process is the culprit to the performance issues within a remote session.
Therefore, the solution is to end the "Touch Keyboard and Handwriting Panel" process within Task Manager. The result is an improved performance post sign-in within Architect and Perspectives.
Note: Unfortunately the "Touch Keyboard and Handwriting Panel" process cannot be disabled, as Microsoft deemed it a "critical service".
Document Location
Worldwide
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Document Information
Modified date:
20 December 2023
UID
ibm17097929