IBM Support

The QueryService status displays "Unknown" within IBM Cognos Administration.

Troubleshooting


Problem

Within IBM Cognos Administration, the QueryService status is "unknown" and the java.exe process is missing from the running process list on the operating system. The error messages that appears in the cogserver.log file are: DPR-DPR-1035 Dispatcher detected an error. XQE-CFG-0003 Failed to load configuration file /configuration\xqe.diagnosticlogging.xml. Problem configuring handler queryServiceHandler.

Cause

The <Cognos install location/configuration/xqe.diagnosticlogging.xml file was manually edited and is now corrupt..

Resolving The Problem

Replace the existing corrupt diagnosticlogging.xml file.with a valid backup.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21632341