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Query Service metric tab appear without values, only 0.

Troubleshooting


Problem

Metrics - QueryService tab does not show any values, only 0.

Symptom

XQE error message :
<log>
<event component="XQE" group="Exception" level="ERROR" thread="27" timestamp="xxxx-xx-xx xx:xx:xx.xxx"><![CDATA[java.rmi.ConnectIOException: Exception creating connection to: customer_hostname; nested exception is:
    java.io.IOException:  Reason: java.net.ConnectException: Rejected xxxx (Connection refused)
    at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:631)
    at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:216)
.......

Cause

Wrong hostname in [CA_root_path]/configuration/cogstartup.xml

Resolving The Problem

- Stop Cognos
- Backup [CA_root_path]/configuration/cogstartup.xml
- Open cogstartup.xml with a text Editor  (line 34)
- Replace content
<crn:parameter name="hostName">
   <crn:value xsi:type="xsd:string">customer_hostname</crn:value>
by
<crn:parameter name="hostName">
   <crn:value xsi:type="xsd:string">localhost</crn:value>
- Save
- Start Cognos .

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
13 February 2020

UID

ibm12404029