IBM Support

QE-DEF-0285 The logon failed

Question & Answer


Question

When trying to open a report in certain circumstances, getting above error message. The error always comes when trying to run the report from the design mode. When clicking on the report name in COGNOS Connection it pops up on every second attempt. Testing datasource connection from COGNOS connection fails on every second test regardless of the dispatcher. QE-DEF-0285 The logon failed. QE-DEF-0323 The DSN(ODBC)/ServiceName is invalid. Either the DSN is missing or the host is inaccessible.

Cause

Wrong/different ODBC data source name on one of dispatchers

Answer

Make sure the data source names (DSN) are the same on each Dispatchers.

Open "ODBC Data Source Administrator (32-bit)" C:\Windows\SysWOW64\odbcad32.exe

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22000141