Troubleshooting
Problem
Attempts to publish application to the runtime environment result in "Failure uploading archive to server" error when using IBM WebSphere Integration Developer.
Symptom
Receive a "Failure uploading archive to server" message when trying to publish an application to the WebSphere Process Server, the WebSphere Enterprise Service Bus, or the WebSphere Application Server.
Cause
This message may result if the machine running WebSphere Integration Developer cannot ping the IP address or host name that is contained in the target server's serverindex.xml.
Diagnosing The Problem
1. Open the serverindex.xml file in the following location:
On Windows:
<SERVER_HOME>\profiles\<PROFILENAME>\config\cells\<CELLNAME>\nodes\<NODENAME>\serverindex.xml file
(Replace "profiles" with "pf" if version is 6.1 or 6.2)
On Linux:
<SERVER_HOME>/profiles/<PROFILENAME>/config/cells/<CELLNAME>/nodes/<NODENAME>/serverindex.xml file
(Replace "profiles" with "pf" if version is 6.1 or 6.2)
2. Locate the value of "hostname" specified in the file, try to ping that host name from the machine running WebSphere Integration Developer. If the host name cannot be pinged, that indicates a problem with the host name.
Resolving The Problem
On the server machine modify the value of "hostname" defined in serverindex.xml and change the host name to one that the machine running WebSphere Integration Developer can resolve.
For location of the serverindex.xml file, see "Diagnosing the problem" above.
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Document Information
Modified date:
15 June 2018
UID
swg21450962