IBM Support

Promotions applied at Orderline level using Webcom is always putting the discount into ChargeperLine

Troubleshooting


Problem

Attempts to apply promotions at orderline level puts discount in to chargeperline in IBM Sterling Selling and Fulfillment Suite.

Symptom

Steps to Simulate:

  1. Create pricing rule such that if order total is greator than 1000$ then give a discount of 200$.

  2. Create a sales order having one orderline with 2 quantity of same item having price as 800 $. Order total will be 1400 $. i.e. 1600$ - 200$.

  3. Add a payment method to this order.

  4. Run ProcessorderPayment API to authorize the amount.

  5. Schedule and release the order.

  6. Create and confirm the shipment.

  7. Create shipment Invoice.

  8. Run process order payment to collect the amount.

  9. Create a derived returned order from this sales order such that RO will only have one item in it for the first time.

  10. Call processreturnOrder API on this return order.

  11. Authorize and then release this return order.

  12. Create order Invoice for this return order

  13. Run processOrderPayment on this return order and check how much amount is getting refunded to customer. 800$ gets refunded.

  14. Perform Step 9 to 13 for returning second item from line. You will see that 600$ will be refunded.

Cause

This behavior is Working As Designed.

Diagnosing The Problem

When orders created in call center are having any line level applicable promotions configured through SBC, CCC is putting the entire line level discount into Chargeperline irrespective of whether the line is absolute or percentage discount.
Since charge per line is being added instead of chargeperunit, during invoicing sterling is applying the entire line discount when the first item/quantity is being shipped out and when refunding, it is considering the entire line discount in the refund only if customer returns the last unit of that line which has charge per line.
Refund amount contains a line level promotional discount only if the last quantity of the item is returned

Resolving The Problem

Using the Sterling Business Center application , if you configure an item with charges, the charges are always applied as chargePerLine.
If you want the charges to be applied as chargePerUnit, then you need to implement the OMPGetReturnOrderPriceUE user exit. But, if customer wants charge per Unit to be applied when the order is created via Webcom instead of waiting for the return so that the invoicing behavior also is consistent then they can achieve this by implementing orderRepricingUE. From within this UE, call getOrderPrice and massage the output to include PerUnit and PerLine charges.

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Document Information

Modified date:
16 June 2018

UID

swg21969237