Troubleshooting
Problem
User launches the Controller client. Inside Controller, user clicks "Help - Contents". User receives error.
Symptom
Navigation to the webpage was canceled
What you can try:
Refresh the page.
Then:
This program cannot display the webpage
Most likely causes:
* You are not connected to the Internet
* The website is encountering problems.
* There might be a typing error in the address.
Cause
Incorrect IIS (web server) configuration on the Controller application server.
For example, in one real-life customer example, the folder "C:\Program Files (x86)\ibm\cognos\c10\webcontent" incorrectly contained an IIS configuration file ("web.config") whose contents were to create a redirect (to /ibmcognos/controllerbin/ccr.exe).
- In turn, the cause for this was that the redirect was intended to be created for the virtual directory 'controller', but accidentally created on the wrong virtual directory ("controllerhelp").
Resolving The Problem
Ensure that:
- If it does, then rename this file to "web.config.bad" and re-try.
1. The relevant location (e.g. "C:\Program Files (x86)\ibm\cognos\c10\webcontent") does *not* contain a file "Web.Config"
Steps:
1. As a precaution, create a backup (e.g. virtual snapshot) of the Controller application server
2. Logon to the Controller application server as a Windows administrator
3. Browse to the relevant folder
- TIP: By default, this is C:\Program Files (x86)\ibm\cognos\c10\webcontent
4. If there is a file called "web.config" (inside this folder), then delete it (or rename it to "web.config.bad")
5. Launch IIS Manager
6. Locate the virtual directory 'controllerhelp'
7. Right-click on it, and choose 'Manage Virtual Directory - Advanced Settings'
8. Check that it looks correct:
9. Make changes/correct as necessary
10. Test.
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Document Information
Modified date:
15 June 2018
UID
swg21631978