IBM Support

Product browsing in Call Center for Commerce 9.4 leads to error YFC0006

Troubleshooting


Problem

Attempts to browse products in IBM Call Center for Commerce leads to the error YFC0006 com.google.common.util.concurrent.Futures.inCompletionOrder.

Symptom

Complete error message is as follows:

ErrorCode="YFC0006"
ErrorDescription="ThreadID:258::Message:com.google.common.util.concurrent.Futures.inCompletionOrder(Ljava/lang/Iterable;)Lcom/google/common/collect/ImmutableList;"
ErrorRelatedMoreInfo="com.google.common.util.concurrent.Futures.inCompletionOrder(Ljava/lang/Iterable;)Lcom/google/common/collect/ImmutableList;"

Cause

Cassandra isn't intended for use with CCC screens yet.

Environment

Sterling Order Management 9.4.0 HF14
IBM Call Center for Commerce 9.4.0.9
Apache Cassandra 2.2.6

Resolving The Problem

Support for Cassandra in this case is very limited and it definitely isn't intended for use with CCC screens. This feature is not meant for general usage. For more information about using this feature, please contact IBM Support and request for further information from Product Management.

Also note, Cassandra support is not published in 9.5 as well. It will be considered for post 9.5.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
10 May 2022

UID

swg21984742