IBM Support

Probe for NFM-P failed with AMQ119007 Cannot connect to server

Troubleshooting


Problem

The probe for Nokia Network Functions Manager for Packet failed to connect to the Nokia NFM-P.
The port numbers defined for the EJBPort and HTTPPort properties are open up in the firewall.
The probe has been configured to use the required Oracle Java 1.8 U131 or higher.
These error messages are seen in the probe log.
Error: E-JPR-000-000: NFM-P: createTopicConnection with details ( user: myname, passw: mypassword) failed : javax.jms.JMSException: Failed to create session factory
Error: E-JPR-000-000: Caused by: ActiveMQNotConnectedException[errorType=NOT_CONNECTED message=AMQ119007: Cannot connect to server(s). Tried with all available servers.]
Error: E-JPR-000-000: GetJmsEvents: Exception raised while trying to connect to the JMS : javax.jms.JMSException: Failed to create session factory
Error: E-JPR-000-000: caused by: AMQ119007: Cannot connect to server(s). Tried with all available servers.
Warning: W-JPR-000-000: NFM-P: failed while try connecting to JMS!
Error: E-JPR-000-000: Failed to connect; ProbeException: javax.jms.JMSException: Failed to create session factory; JMSException: Failed to create session factory; ActiveMQNotConnectedException: AMQ119007: Cannot connect to server(s). Tried with all available servers.
Information: I-UNK-000-000: Probewatch: Unable to get events. Failed to connect; ProbeException: javax.jms.JMSException: Failed to create session factory; JMSException: Failed to create session factory
.
Debug: D-JPR-000-000: com.ibm.tivoli.netcool.omnibus.probe.ProbeException: javax.jms.JMSException: Failed to create session factory
        at com.ibm.tivoli.oidk.ProbeImpl.endpointConnect(Unknown Source)
        at com.ibm.tivoli.oidk.ProbeImpl.connect(Unknown Source)
        at com.ibm.tivoli.netcool.omnibus.probe.framework.ProbeRunner.connect(Unknown Source)
        at com.ibm.tivoli.netcool.omnibus.probe.framework.ProbeRunner.connectAndRun(Unknown Source)
        at com.ibm.tivoli.netcool.omnibus.probe.framework.ProbeRunner.run(Unknown Source)
        at com.ibm.tivoli.netcool.omnibus.oidk.Probe.start(Unknown Source)
        at com.ibm.tivoli.netcool.omnibus.oidk.Probe.main(Unknown Source)
Caused by: javax.jms.JMSException: Failed to create session factory
        at org.apache.activemq.artemis.jms.client.ActiveMQConnectionFactory.createConnectionInternal(ActiveMQConnectionFactory.java:757)
        at org.apache.activemq.artemis.jms.client.ActiveMQConnectionFactory.createTopicConnection(ActiveMQConnectionFactory.java:326)
        at com.ibm.tivoli.netcool.integrations.nfmp.GetJmsEvents.connect(Unknown Source)
        ... 7 more
Caused by: ActiveMQNotConnectedException[errorType=NOT_CONNECTED message=AMQ119007: Cannot connect to server(s). Tried with all available servers.]
        at org.apache.activemq.artemis.core.client.impl.ServerLocatorImpl.createSessionFactory(ServerLocatorImpl.java:787)
        at org.apache.activemq.artemis.jms.client.ActiveMQConnectionFactory.createConnectionInternal(ActiveMQConnectionFactory.java:755)
        ... 9 more

Cause

The possible causes are SSL related issues, incorrect keystore type or firewall blocking the connection.

Diagnosing The Problem

Ensure the Probe and Nokia NFM-P are both using the same KeyStore type.
The probe default to KeyStore type of PKS.

If Nokia NFP-P is using Java 9 which will default to KeyStore type of PKCS12 then the probe will need to be configured to use the same KeyStore type of PKCS12.

Run this command to convert the jks keystore to pkcs12 and update the probe properties.
keytool -importkeystore -srckeystore /opt/IBM/tivoli/netcool/omnibus/java/security/nokia_nfmp_keystore.jks
-destkeystore /opt/IBM/tivoli/netcool/omnibus/java/security/nokia_nfmp_keystore.p12 -deststoretype pkcs12
Change these probe properties
CertificateStoreType             : 'JKS'
TrustStore                         : '/opt/IBM/tivoli/netcool/omnibus/java/security/nokia_nfmp_keystore.jks'
CertificateStore                   : '/opt/IBM/tivoli/netcool/omnibus/java/security/nokia_nfmp_keystore.jks'
to
CertificateStoreType             : 'PKCS12'
TrustStore                         : '/opt/IBM/tivoli/netcool/omnibus/java/security/nokia_nfmp_keystore.p12'
CertificateStore                   : '/opt/IBM/tivoli/netcool/omnibus/java/security/nokia_nfmp_keystore.p12'
Enable SSL debug logging on the probe as this technote.
How to enable Java SSL debug logging
https://www.ibm.com/support/pages/node/464593

Do a full handshake debug.
-Djavax.net.debug=all:handshake:verbose

In addition, enable nonnative debug as per this technote.
Non-Native probe debug logging
https://www.ibm.com/support/pages/non-native-probe-debug-logging

Check the non-native and SSL debug log for any failure in SSL Handshakes.
If there are no SSL Handshake issues, then check the SSL log on whether the connection was redirected to another port number.
That port number could be blocked by the firewall.
Ensure that the mentioned port number is open in the firewall for the probe to connect to the Nokia.
 

Resolving The Problem

Correct the keystore type on the probe if it is not matching with that of the Nokia NFM-P.
Fix up any SSL handshakes found in the SSL debug log.
In the firewall open the port number that the probe has been redirected to.

Document Location

Worldwide

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSSHTQ","label":"Tivoli Netcool\/OMNIbus"},"ARM Category":[{"code":"a8m50000000L2EHAA0","label":"Probes->1 Individual Probes->Nokia NFM-P nco_p_nokia_nfmp"}],"ARM Case Number":"TS003979166","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

TS003979166

Product Synonym

nco_p_nokia_nfmp

Document Information

Modified date:
07 August 2020

UID

ibm16257461