IBM Support

Planning Analytics Spreadsheet Service (TM1Web) session timeout error after connecting to PMPSVC

Troubleshooting


Problem

The client logins to TM1web then logins to PMPSVC using same browser. If the user go back to TM1web, the user will get "session timeout".
This only occurs If TM1web and PMPSVC are installed on same machine.


image 8907

Cause

The root cause of this issue is the browser's limitation of session cookie when more than one web app is running on the same host domain.

Resolving The Problem

There is a workaround and a solution.
- The workaround would be using two different browsers to access TM1web and PMPSVC.
-  The solution is to update the following line in server.xml. This file is located in <tm1web_installation_dir>\wlp\usr\servers\tm1web
<httpSession cookieHttpOnly="true" cookieName="TM1WebJSESSIONID" />
Then restart IBM Planning Analytics Spreadsheet Service.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m0z000000cwgYAAQ","label":"How to"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
15 April 2021

UID

ibm16435215