Troubleshooting
Problem
After an upgrade of the Planning Analytics Administration Agent (PA Agent) it's not possible to see the TM1 Databases in Planning Analytics Workspace Administration anymore.
The "messages.txt" log file of the Planning Analytics Administration Agent in "../tm1_64/paa_agent/wlp/usr/servers/kate-agent/logs" include a bulk of error messages:
...
0000003c com.ibm.pa.kate.agent.service.PAKateAgentService E Exception java.lang.NullPointerException at com.fasterxml.jackson.databind.deser.SettableBeanProperty.getName(SettableBeanProperty.java:352) at com.fasterxml.jackson.databind.deser.BeanDeserializerBuilder.addProperty(BeanDeserializerBuilder.java:177) at com.fasterxml.jackson.databind.deser.BeanDeserializerFactory.addBeanProps(BeanDeserializerFactory.java:598) at com.fasterxml.jackson.databind.deser.BeanDeserializerFactory.buildBeanDeserializer(BeanDeserializerFactory.java:234) at com.fasterxml.jackson.databind.deser.BeanDeserializerFactory.createBeanDeserializer(BeanDeserializerFactory.java:143) at com.fasterxml.jackson.databind.deser.DeserializerCache._createDeserializer2(DeserializerCache.java:411) at com.fasterxml.jackson.databind.deser.DeserializerCache._createDeserializer(DeserializerCache.java:349) at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCache2(DeserializerCache.java:264) at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCacheValueDeserializer(DeserializerCache.java:244) at com.fasterxml.jackson.databind.deser.DeserializerCache.findValueDeserializer(DeserializerCache.java:142) at com.fasterxml.jackson.databind.DeserializationContext.findRootValueDeserializer(DeserializationContext.java:476) at com.fasterxml.jackson.databind.ObjectMapper._findRootDeserializer(ObjectMapper.java:4389) at com.fasterxml.jackson.databind.ObjectMapper._readMapAndClose(ObjectMapper.java:4198) at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.java:3205) at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.java:3173) at com.ibm.pa.kate.agent.service.PAKateAgentService.getServersStatus(PAKateAgentService.java:531) at com.ibm.pa.kate.agent.service.PaKateServerUnresponsiveNotificationService.checkNotificationThresholds(PaKateServerUnresponsiveNotificationService.java:55) at com.ibm.pa.kate.agent.scheduler.ServerUnresponsiveNotificationTask.run(ServerUnresponsiveNotificationTask.java:34) at java.util.TimerThread.mainLoop(Timer.java:566) at java.util.TimerThread.run(Timer.java:516)
...
Symptom
Planning Analytics Administration Agent isn't working anymore. It's generate a bulk of error messages in the messages.txt log file.
In Planing Analytics Workspace Administration the TM1 databases are not displayed or displayed with wrong information.
Cause
The install and/or upgrade of the Planning Analytics Administration Agent wasn't successful.
Environment
Windows Server
Resolving The Problem
The problem could be related to one or more old files in the paa_agent folder structure.
To solve this problem follow this steps:
1. Stop the "IBM Planning Anylytics Administration Agent" service
2. Remove the the cache folders: ".logs" and ".classCache" in ../tm1_64/paa_agent/wlp/usr/servers
3. Remove the folder: "workarea" in ../tm1_64/paa_agent/wlp/usr/servers/kate-agent
4. Restart the "IBM Planning Anylytics Administration Agent" service
Document Location
Worldwide
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Product Synonym
PAW; PA Workspace; PA Agent; PAA
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Document Information
Modified date:
03 July 2020
UID
ibm16243838