Troubleshooting
Problem
Customer has enabled "useInternalPdfViewer = true" functionality (which enabled local 'pdfium' PDF rendering by the Controller client, rather than using an external third-party PDF reader).
Afterwards, user runs any standard report. This initially appears OK in HTML (as expected).
However, if the user changes the output 'format' to PDF, then the report does not appear (as expected) in the Controller client's PDFViewer functionality popup screen.
Instead, either (depending on environment):
- It appears in the local Adobe Reader client
- A message appears asking the user to choose which program to open PDF files in.
Symptom
Example (if Adobe Reader not installed):
File Download
Do you want to save this file, or find a program online to open it?
Name: New Report.pdf
Type: Unknown File Type
From: <appserver>
Find Save Cancel
Cause
Limitation of some environments.
Environment
This problem has been seen in some (rare) Controller 10.4.1 and 10.4.2 environments.
Resolving The Problem
Fix:
Limitation of some environments.
Workaround:
Perform both of the following:
1. Make sure using Controller 10.4.2 (or later)
2. Reconfigure Controller application server to use the 'Embedded Report Library' (ccrReports) engine (instead of Cognos Analytics) to power the standard reports.
- TIP: For instructions, see separate IBM Technote #1489047.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
07 September 2020
UID
ibm16327157