IBM Support

Patches are not available to push down from Guardium Central Manager to Managed Unit

Troubleshooting


Problem

I built a new Guardium Central Manager (CM) and successfully installed some patches on it. The patches are not available to push down to Managed Units (MU) from the GUI as expected.

Symptom

  • CLI show system patch installed on the CM shows patches were successfully installed.
  • CLI show system patch available on the CM shows no patches are available.
  • Patches are not listed to be pushed down to MU from the GUI.

    • v9 Administration Console -> Central Management -> Central Management -> Patch Distribution

      v10 Manage -> Central Management -> Central Management -> Patch Distribution

Cause

One possible cause is that the patches were installed on the system before the unit type was set as manager.

The default behavior for non manager units is to delete the patch files after successful install. If the unit that is now a CM was not a CM when the patches were installed, they will not be available to push down to the managed units.

Resolving The Problem

The unit type should be set before any patches are installed. It should be set as part of the set up and basic configuration after building the appliance.

The problem can be resolved by uploading the patches to the CM fileserver again. Then they will be available to push down to the MU. Reinstall of the patches on the CM is not required.

If this does not resolve the problem there may be a different underlying cause. If you need to open a PMR with Guardium support please attach

  • support must_gather patch_install_issues from CM and one MU
  • support must_gather app_issues from the CM. Start the debugger and attempt to push down patch from the GUI while it is running.

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Document Information

Modified date:
16 June 2018

UID

swg21993837