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OUTOFMEMORY error in Content Manager indexing in 11.0.10 and later

Troubleshooting


Problem

Cognos Analytics 11.0.10 has a fix for PI91883 OUTOFMEMORYERROR IN CM INDEXING but the issue still occurs. Dump files are created in bin64 folder of Content Manager installation The following record is logged in cogaudit.log: CM.IndexSynchronization.run: FAILED.java.lang.OutOfMemoryError

Cause

CM.IndexSynchronization consumes too much Java memory

Resolving The Problem

Set the following CM advanced setting in Administration to reduce the BlockingQueue size from 1000 to 100: 

ContentManagerService->Settings->Advanced Settings

CM.ASYNCSERVICEBLOCKINGQUEUECAPACITY 100

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"}],"Version":"11.0.10","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22016751