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OrderHeaderKey is getting updated to null in yfs_shipment table when the user is changing the ETA from the Shipment dates screen on UI in IBM Sterling Order Management

Question & Answer


Question

Why does the OrderHeaderKey get updated to Null when the ETA for the shipment is revised?

Cause

As per design, we do not expect OrderHeaderKey at shipment header level when any shipment line is present. Since one shipment can be created from multiple orders/order lines.

Answer

Sample Scenario:

  1. Create Order, schedule the order and release the Order.

     
  2. Create the Shipment using the following input XML of CreateShipment API

    <Shipment BuyerOrganizationCode="DEFAULT" DocumentType="0001" EnterpriseCode="DEFAULT" SellerOrganizationCode="DEFAULT" ShipNode="N1" OrderHeaderKey="20180615010651179154" OrderNo=""><ShipmentLines>
    <ShipmentLine ItemID="I1" ProductClass="A" Quantity="1"  SegmentType="" Segment="" UnitOfMeasure="EACH" OrderLineKey="20180615010651179155" OrderHeaderKey="20180615010651179154" OrderReleaseKey="20180615010740179164">
    </ShipmentLine>
    </ShipmentLines></Shipment>

     
  3. Revise ETA from UI (Shipment Dates Screen) for any shipment that is still not delivered. Click on Save.

     
  4. Check the shipment audit where orderheaderkey is updated to null.
    You could observe that the OrderHeaderKey on the table YFS_SHIPMENT for the above shipment is updated to Null.

     

Passing OrderHeaderKey at shipment header level is not supported. It must be referenced or passed at shipment line level only

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
29 June 2018

UID

ibm10715913